Author Topic: mailserver " BAD Error in IMAP command APPEND: Invalid arguments"  (Read 455 times)

Jaydenzhao

  • Newbie
  • *
  • Posts: 2
  • Karma: +0/-0
I also encountered the "APPEND"error when configuring mailServer by Example VM Setup Guide,The official solution is:
BAD Error in IMAP command APPEND:
Invalid arguments
A. This usually occurs when the SPECimap/IMAP*.config files are in DOS format instead of UNIX format. Edit the config files with vi and do the following to convert to UNIX format:
:set ff=unix
:w
:q

but i not find the IMAP*.config,so i change the system  language to "en_us:UTF-8",and try set all file ff=unix,still have this error

what can i do to slove it

nohup.out  :
2022-03-02 19:39:37:155 message initialization called by thread Thread-15
2022-03-02 19:39:37:156 LoadGenerator: Threads started, test in progress...
2022-03-02 19:39:37:157 Thread-15 has userMin = 126 and userMax = 250
2022-03-02 19:39:37:157 EVENT: Initializing messages for user: test126
2022-03-02 19:39:37:157 specimapclient: Waiting for threads...
2022-03-02 19:39:37:156 EVENT: Initializing messages for user: test1
2022-03-02 19:39:37:156 message initialization called by thread Thread-16
2022-03-02 19:39:37:157 Thread-16 has userMin = 251 and userMax = 375
2022-03-02 19:39:37:157 EVENT: Initializing messages for user: test251
2022-03-02 19:39:37:157 message initialization called by thread Thread-17
2022-03-02 19:39:37:158 Thread-17 has userMin = 376 and userMax = 500
2022-03-02 19:39:37:158 EVENT: Initializing messages for user: test376
2022-03-02 19:39:39:580 Warning: ImapMessageInitEventScheduler "APPEND" (message) received error:test251t3 BAD Error in IMAP command APPEND: Invalid arguments.
2022-03-02 19:39:39:581 test251 level(0)folder("INBOX" -- Received FATAL ERROR during appendMessage
2022-03-02 19:39:39:582 ********************************************************************************************
2022-03-02 19:39:39:582 ********************************************************************************************
2022-03-02 19:39:39:583
2022-03-02 19:39:39:583 ERROR Loading mailstore!!  Mailstore is not complete and will not work for SPECvirt-imap runs.
2022-03-02 19:39:39:583
2022-03-02 19:39:39:584 ********************************************************************************************
2022-03-02 19:39:39:584 ********************************************************************************************
2022-03-02 19:39:40:274 Warning: ImapMessageInitEventScheduler "APPEND" (message) received error:test126t3 BAD Error in IMAP command APPEND: Invalid arguments.
2022-03-02 19:39:40:274 test126 level(0)folder("INBOX" -- Received FATAL ERROR during appendMessage

DavidSchmidt

  • Moderator
  • Newbie
  • *****
  • Posts: 19
  • Karma: +2/-1
Re: mailserver " BAD Error in IMAP command APPEND: Invalid arguments"
« Reply #1 on: March 08, 2022, 10:11:38 AM »
Hi Jayden,

What mailserver are you using? Can you provide your mailserver's configuration file? For example, if you are using Dovecot, please provide the dovecot.conf file.

Richard

  • Newbie
  • *
  • Posts: 2
  • Karma: +0/-5
Re: mailserver " BAD Error in IMAP command APPEND: Invalid arguments"
« Reply #2 on: March 24, 2022, 02:09:15 AM »
What IMAP server (and version) are you using?

my ford benefits
« Last Edit: March 24, 2022, 11:59:54 PM by Richard »

Jaydenzhao

  • Newbie
  • *
  • Posts: 2
  • Karma: +0/-0
Re: mailserver " BAD Error in IMAP command APPEND: Invalid arguments"
« Reply #3 on: March 24, 2022, 05:34:10 AM »
Hi Jayden,

What mailserver are you using? Can you provide your mailserver's configuration file? For example, if you are using Dovecot, please provide the dovecot.conf file.

dovecot-2.2.10-1_14.

Thank you