Author Topic: Invalidation Run due to validation errors in web workload  (Read 149 times)

Miles

  • Jr. Member
  • **
  • Posts: 72
  • Karma: +0/-0
Invalidation Run due to validation errors in web workload
« on: June 15, 2018, 05:49:38 AM »
Hi
I rebuild and run for 1-tile.
The test completed but following compliance errors occurred.

I use 40G NIC and build VF in my SUT and client;
example VM script "optdirs-sc2013-v1.04" and "helper-sc2013-v1.03" are used to deploy.
All VM is installed as RHEL 6.5.

I have modified "java.security" on client to make sure SSLv3 is enabled.

I have no idea so far so I will re-install and re-deploy web workload VMs

Thanks.

Code: [Select]
Errors

Quality of Service Errors
•Iteration 1    failed 95% TIME GOOD QoS.:    Achieved:  75.3%
•Iteration 1    failed 99% TIME TOLERABLE QoS.:    Achieved:  84.8%

Validation Errors
•1792 Validation Errors for Iteration 1  :   client1:1010 - home   
•4563 Validation Errors for Iteration 1  :   client1:1010 - search   
•4786 Validation Errors for Iteration 1  :   client1:1010 - catalog   
•11408 Validation Errors for Iteration 1  :   client1:1010 - product   
•10635 Validation Errors for Iteration 1  :   client1:1010 - fileCatalog   
•4060 Validation Errors for Iteration 1  :   client1:1010 - file   
•1192 Validation Errors for Iteration 1  :   client1:1010 - download   

Request Distribution Errors
•Weighted percentage difference (1.80%) for product in Iteration 1 is too high. Expected: 276900 requests, Actual: 256733
•Weighted percentage difference (1.58%) for fileCatalog in Iteration 1 is too high. Expected: 251743 requests, Actual: 234075
•Sum of weighted percentage difference (7.05%) exceeds 1.5% for Iteration 1
« Last Edit: June 15, 2018, 06:02:03 AM by Miles »

RamyaMeruva

  • Newbie
  • *
  • Posts: 13
  • Karma: +0/-0
Re: Invalidation Run due to validation errors in web workload
« Reply #1 on: June 20, 2018, 02:19:58 PM »
Hi Miles,

We need additional info about your setup. The logs u attached did not have anything suspicious at all. Looks like the problem is not related to SSL at all.

Can u post Control.config, primectrl.log and client_1088.log ?

Also, set DEBUG to 5, rerun & send logs.

Thanks,
Ramya

Miles

  • Jr. Member
  • **
  • Posts: 72
  • Karma: +0/-0
Re: Invalidation Run due to validation errors in web workload
« Reply #2 on: June 25, 2018, 02:43:26 AM »
Hi
1.I have re-installed the VMs and it can complete the 4T4W-run.
   But still errors exist even QOS of each tile is "1.00".
 
Validation Errors:
• Run 1 ◦ Tile 3 ◾ Web Server Errors: ◾Page download errors (121271) >= 0.01 * Requests ( 121271) = 1212.71
◾Total validation errors (121271) >= 0.005 * TotalRequests ( 1788438) =8942.19


2. I found following errors in /etc/httpd/logs/error_log in infraserver
Code: [Select]
[Mon Jun 25 16:54:09 2018] [notice] suEXEC mechanism enabled (wrapper: /usr/sbin/suexec)
[Mon Jun 25 16:54:09 2018] [warn] module fastcgi_module is already loaded, skipping
[Mon Jun 25 16:54:09 2018] [notice] Digest: generating secret for digest authentication ...
[Mon Jun 25 16:54:09 2018] [notice] Digest: done
[Mon Jun 25 16:54:09 2018] [notice] FastCGI: wrapper mechanism enabled (wrapper: /usr/sbin/suexec)
[Mon Jun 25 16:54:09 2018] [notice] FastCGI: process manager initialized (pid 8147)
[Mon Jun 25 16:54:09 2018] [warn] FastCGI: server "/var/www/fcgi-bin/besim_fcgi.fcgi" (uid 48, gid 48) started (pid 8148)
suexec policy violation: see suexec log for more details
[Mon Jun 25 16:54:09 2018] [warn] FastCGI: server "/var/www/fcgi-bin/besim_fcgi.fcgi" (pid 8148) terminated by calling exit with status '107'
[Mon Jun 25 16:54:09 2018] [notice] Apache/2.2.15 (Unix) DAV/2 mod_auth_kerb/5.4 mod_auth_pgsql/2.0.3 mod_fastcgi/2.4.6 mod_nss/2.2.15 NSS/3.14.0.0 Basic ECC PHP/5.3.3 mod_ssl/2.2.15 OpenSSL/1.0.0-fips SVN/1.6.11 mod_wsgi/3.2 Python/2.6.6 mod_perl/2.0.4 Perl/v5.10.1 configured -- resuming normal operations
[Mon Jun 25 16:54:10 2018] [warn] FastCGI: server "/var/www/fcgi-bin/besim_fcgi.fcgi" (uid 48, gid 48) started (pid 8186)
suexec policy violation: see suexec log for more details
  Does it mean I made mistake in infraserver deployment?
  Thanks.
« Last Edit: June 25, 2018, 05:10:50 AM by Miles »

RamyaMeruva

  • Newbie
  • *
  • Posts: 13
  • Karma: +0/-0
Re: Invalidation Run due to validation errors in web workload
« Reply #3 on: June 25, 2018, 06:36:50 PM »
Hi Miles,

From specvirt-perf.html, I can see that you have multiple tiles up and running. The validation errors on tile 3 seems to be because of resourcing/tuning constraints (networking most likely).  Please refer to latest published results on how to tune your testbed to support more tiles.

Please refer to https://www.spec.org/virt_sc2013/docs/SPECvirt_RunRules.html section 2.3.1 to see how Qos is calculated for webserver.

Thanks,
Ramya