Author Topic: Run the benchmark failed  (Read 2935 times)

onlyloveu2

  • Newbie
  • *
  • Posts: 41
  • Karma: +0/-0
Re: Run the benchmark failed
« Reply #45 on: November 06, 2015, 04:56:02 PM »
[root@appserver opt]# find . -name "domain.xml"
./glassfish3/glassfish/lib/templates/domain.xml
./glassfish3/glassfish/domains/spec2004-1/config/domain.xml
./glassfish3/glassfish/domains/domain1/config/domain.xml
./SPECjAppServer2004/bin/domain.xml
./appvm_scripts/files/domain.xml
./appvm_scripts/files/Glassfish312_SPECjApp_BuildScripts/domain.xml
[root@appserver opt]#


is ./glassfish3/glassfish/domains/spec2004-1/config/domain.xml  ?


</domain>[root@appserver opt]# cat ./glassfish3/glassfish/domains/spec2004-1/config/domain.xml | grep max
    <connector-connection-pool max-pool-size="250" pool-resize-quantity="16" steady-pool-size="16" name="jms/QueueConnectionFactory" resource-adapter-name="jmsra" connection-definition-name="javax.jms.QueueConnectionFactory">
      <property name="max-poolsize" value="1000"></property>
      <property name="max-pool-size" value="512"></property>
        <jvm-options>-Dosgi.shell.telnet.maxconn=1</jvm-options>
            <http default-virtual-server="server" max-connections="250">
            <http default-virtual-server="server" max-connections="250">
            <http default-virtual-server="__asadmin" max-connections="250" encoded-slash-enabled="true">
        <thread-pool name="admin-thread-pool" max-thread-pool-size="50" max-queue-size="256"></thread-pool>
        <thread-pool name="thread-pool-1" max-thread-pool-size="200"></thread-pool>
        <jvm-options>-Dosgi.shell.telnet.maxconn=1</jvm-options>
            <http default-virtual-server="__asadmin" max-connections="250">
        <thread-pool max-thread-pool-size="200" name="thread-pool-1"></thread-pool>
[root@appserver opt]#
« Last Edit: November 06, 2015, 04:58:08 PM by onlyloveu2 »

onlyloveu2

  • Newbie
  • *
  • Posts: 41
  • Karma: +0/-0
Re: Run the benchmark failed
« Reply #46 on: November 08, 2015, 09:25:24 AM »
1. How to set appserver's domain.xml max-pool-size, not found max-wait-time.
2. How to set dbserver's shared_buffers and max_connections.
3. all servers and client configure files in Attachments, please check.

onlyloveu2

  • Newbie
  • *
  • Posts: 41
  • Karma: +0/-0
Re: Run the benchmark failed
« Reply #47 on: November 08, 2015, 09:26:07 AM »
client configure

lroderic

  • Moderator
  • Full Member
  • *****
  • Posts: 145
  • Karma: +6/-0
Re: Run the benchmark failed
« Reply #48 on: November 09, 2015, 12:46:59 PM »
I'm sorry this is taking so long. Please set NUM_WORKLOADS=1 and POLL_INTERVAL_SEC=2400 to run only appserver for a longer time. Then zip and post the .out files. I want to see if it's a problem with appserver over time or appserver once you add the other workloads.

lroderic

  • Moderator
  • Full Member
  • *****
  • Posts: 145
  • Karma: +6/-0
Re: Run the benchmark failed
« Reply #49 on: November 09, 2015, 01:12:18 PM »
On the client, edit /opt/SPECjAppServer2004/config/run.properties and change:

dlrAgentMinHeapMB = 512
dlrAgentMaxHeapMB = 512

Then rerun a test.

Lisa

onlyloveu2

  • Newbie
  • *
  • Posts: 41
  • Karma: +0/-0
Re: Run the benchmark failed
« Reply #50 on: November 10, 2015, 09:20:25 AM »
return error...