Author Topic: System shutdown when setup_files.sh was executed in infraserver VM  (Read 173 times)

Miles

  • Jr. Member
  • **
  • Posts: 63
  • Karma: +0/-0
System rebooted when setup_files.sh was executed in infraserver VM.
It halted at "make install"command  and shutdown abnormally in several minutes.
My environment is RHEL6.5 x86_64.


the last message in the terminal:
configure: creating ./config.status
config.status: creating Makefile
config.status: creating cgi-fcgi/Makefile
config.status: WARNING:  'cgi-fcgi/Makefile.in' seems to ignore the --datarootdir setting
config.status: creating include/Makefile
config.status: WARNING:  'include/Makefile.in' seems to ignore the --datarootdir setting
config.status: creating libfcgi/Makefile
config.status: creating examples/Makefile
config.status: WARNING:  'examples/Makefile.in' seems to ignore the --datarootdir setting
config.status: creating fcgi_config.h
config.status: fcgi_config.h is unchanged
config.status: executing depfiles commands
config.status: executing libtool commands
++ make install
Making install in libfcgi
make[1]: Entering directory `/opt/SPECweb2005/Besim/fcgi-2.4.0/libfcgi'
/bin/sh ../libtool  --tag=CC   --mode=compile gcc -DHAVE_CONFIG_H -I. -I..   -I../include -pthread -g -O2 -Wall -MT libfcgi_la-fcgiapp.lo -MD -MP -MF .deps/libfcgi_la-fcgiapp.Tpo -c -o libfcgi_la-fcgiapp.lo `test -f 'fcgiapp.c' || echo './'`fcgiapp.c

lroderic

  • Moderator
  • Full Member
  • *****
  • Posts: 134
  • Karma: +6/-0
Re: System shutdown when setup_files.sh was executed in infraserver VM
« Reply #1 on: June 13, 2017, 10:20:24 AM »
Please rerun ./makeme_infraserver.sh vdb and let us know what happens.

Miles

  • Jr. Member
  • **
  • Posts: 63
  • Karma: +0/-0
Re: System shutdown when setup_files.sh was executed in infraserver VM
« Reply #2 on: June 14, 2017, 01:20:53 AM »
Hi lroderic
The same result occurred  after I reran "./makeme_infraserver.sh vdb".
I cannot get rid of it even I reinstalled a new RHEL6.5 OS.

Thanks for help.

abond

  • Moderator
  • Newbie
  • *****
  • Posts: 30
  • Karma: +5/-0
Re: System shutdown when setup_files.sh was executed in infraserver VM
« Reply #3 on: June 20, 2017, 10:10:55 AM »
Hey Miles,

Are you still seeing this issue?  When you say the system rebooted are you talking about the VM rebooting or the host machine rebooting?  Also, could you attach a copy of the /var/log/messages file after the issue occurs from the VM or host whichever is rebooting on you?  I'd like to see what event the OS sees that could be causing a problem.

Thanks,
Andy

Miles

  • Jr. Member
  • **
  • Posts: 63
  • Karma: +0/-0
Re: System shutdown when setup_files.sh was executed in infraserver VM
« Reply #4 on: June 22, 2017, 04:38:45 AM »
Hi Andy
I rebooted the VM but didn't fix it; then I rebooted both VM and my host but the symptom still existed.
I formatted and reinstalled a RHEL 7.2 to continue.
(I know the example VM scripts only work with CentOS 6.x or RHEL 6.x...)

abond

  • Moderator
  • Newbie
  • *****
  • Posts: 30
  • Karma: +5/-0
Re: System shutdown when setup_files.sh was executed in infraserver VM
« Reply #5 on: June 23, 2017, 01:59:25 PM »
Hey Miles,

I can try to take a look at it on a RHEL 7 system.  Would you be able to give it try on a RHEL6 or CentOS6 VM for the infraserver?  We've tested it in those environments.

Thanks,
Andy

Miles

  • Jr. Member
  • **
  • Posts: 63
  • Karma: +0/-0
Re: System shutdown when setup_files.sh was executed in infraserver VM
« Reply #6 on: June 25, 2017, 11:55:11 AM »
Hi Andy
I tried on RHEL6.5 but failed to run setup_files.sh.
So I rebuild RHEL7.2 and tried a new run.